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1. GstarCAD 2025 Introduction and Installation 

1.1. GstarCAD 2025 Introduction 

GstarCAD 2025 elevates performance to a new level with Hardware Acceleration and other improvements on a series of features, 

significantly enhances the design experience. Exciting new features, including Parametric Constraints, BIM Data Editing, and 

Voice Annotation, etc., further enrich functionality. Whatõs more, compatibility has been expanded with the addition of Python 

support, empowering more robust customization and automation. Without further ado, let's explore these exciting updates! 

1.2. System Requirement 

Before installing GstarCAD, please confirm whether the specifications of your PC meet the following requirements: 

 

 ̧ OS (Operating System) 

Windows 11 

Windows 10 version 1507 or higher: Home, Professional, Education, and Enterprise (LTSC and Windows 10 S are not 

supported) 

Windows 8.1 (with Update 2919355): Core, Professional, and Enterprise 

Windows 7 SP1 (with latest Windows Updates): Home Premium, Professional, Enterprise, Ultimate 

Windows Server 2016: Standard and Datacenter 

Windows Server 2019: Standard and Datacenter 

Windows Server 2022: Essentials, Standard, Datacenter 

 

Note: Because GstarCAD and related tools are developed and compiled with visual studio 2017, in order to ensure the normal 

operation of the software, the operating system needs to be able to install the environment package of visual studio 2017 

normally. 

 

 ̧ CPU 

1.6 GHz processor (2 GHz or faster Multi-core processor recommended) 

 

 ̧ RAM 

2GB (8GB recommended or higher) 

 

 ̧ Graphics Card 

1 GB GPU (2 GB GPU recommended or higher) 

 

 ̧ Hard Disk 

The system and installation disk need more than 1 GB of space. (10 GB recommended or higher) 

To improve performance, it is recommended that the software be installed and stored on a solid state drive (SSD). 

 

 ̧ Display Resolution 

1024*800 or above; GstarCAD will work best at a resolution of HD and 4K resolution. 
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 ̧ Additional Requirement 

Administrator rights are required to install GstarCAD and license tools. 

.NET Framework 4.8 or above (Only for custom software development). 

The network license server and all workstations running applications that rely on network licenses must support the TCP/IP 

protocol. 

 

1.3. GstarCAD 2025 Installation 

Users can visit www.gstarcad.net to download GstarCAD 2025 to your computer or server.  

 

GstarCAD 2025 Install Wizard will guide the user to install the software in the operating system completely and successfully.  

 

Please follow the steps below to install GstarCAD 2025: 

 

1. Double-click the executable file downloaded and the GstarCAD Install Wizard dialog box will pop up.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.gstarcad.net/
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2. Click Browse       button and choose the destination path where setup will install the files. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click GstarCAD Install Wizard > Options, users can select or deselect the VBA feature according to your need. You can 

also read the System Requirements and Activation Mode of GstarCAD. 
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4. Read the License Agreement and Privacy Policy, and check Agree to Gstarsoft License Agreement and Privacy Policy. 

 

 

5. Click Install button to continue the installation. 
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6. You just need to wait for a few minutes for the Overall Progress. 

 

 

 

7. Then you will see the workspace selection window. Select your favorite workspace and click the Next button. 
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8. Click Finish button to exit the wizard. The GstarCAD wizard has successfully installed GstarCAD 2025. 
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2. Starting up GstarCAD 2025 

2.1. The User Interface 

You can enjoy working at GstarCAD 2025 environment in different ways. You can display and rearrange elements like the 

toolbars, display the command bar, switch between workspaces, change the interface themes and enable the status bar. The 

toolbars and command bar can also be floated anywhere on the screen or docked as well.  

 

 

 

 

 

 

 

 

 

 

2.1.1. Quick Access Toolbar 

Display the frequently used tools like: New, Open, Save, Undo, Redo, Save As, Plot, Plot Preview and Help. Moreover you can 

customize it (adding more commands from the drop-down button) or showing it bellow/above the ribbon.  

  

 

 

 

 

 

1

 

2 3 

4 

 

5 

6 

7 

8 

9 

10 
11 

12 

13 
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2.1.2. Workspace  

2.1.2.1. Workspace Switching 

Switch between workspaces (2D Drafting and GstarCAD Classic). What' more, GstarCAD 2025 provides many color themes, 

such as GstarCAD, Lightblue, Blue, Black, Sliver and Aqua, you can choose your favorite color theme directly. 

   

 

 

 

 

 

 

 

2.1.2.2.  Workspace Command 

The WORKSPACE command allows you to create, modify and save workspaces current. You can customize GstarCAD ribbon or 

classic workspace to suit interface environment needs much easier. 

 

Workspaces are sets of menus, toolbars, palettes, and ribbon control panels that are grouped and organized so that you can 

work in a custom, task-oriented drawing environment. When you use a workspace, only the menus, toolbars, and palettes that 

are relevant to a task are displayed. In addition, a workspace may automatically display the ribbon, a special palette with 

task-specific control panels. You can easily switch between workspaces. The following task-based workspaces are already 

defined in GstarCAD: 2D Drafting and GstarCAD Classic. 
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If you execute WORKSPACE command, the following prompts are displayed:  

Set Current: Sets a current workspace. 

Save As: Saves a current interface configuration as a workspace. 

 

Edit: Opens the Customize User Interface dialog box, Customize tab, where you can make modifications to a workspace. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Rename: Renames a workspace.  

Delete: Deletes a workspace. 

Settings: Opens the Workspace Settings dialog box, which controls the display, menu 

order, and Save settings of a workspace. 

 

2.1.3. Menu Bar 

The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it you can find the 

follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Text, Dimension, Modify, Window, Application, Help, Express 

and Collaboration. 

 

 

 

2.1.3.1. Menus and Shortcut Menus 
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You can use any of the option on the Menus from the menu bar at the top of the 

drawing area. Choose one of the following methods to use a menu:- On the 

menu bar, click a menu name to choose the menu or to expand a list of options.- 

Press Alt and the key for the underlined letter in the menu name to open the 

corresponding menu item list, and then choose menu items from it. For example, 

to edit the drawing file, press <Alt+E> to open the Edit menu.  

 

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you right click an object, status 

bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut menu depend on what you clicked. 

2.1.3.2. Shortcuts Customize 

A faster way to invoke a command is customize its shortcut. The 

CUSTACC command allows you to customize, delete or modify 

existing command shortcuts. To access this command go through 

the menu bar, under tools, select customize and choose Shortcuts 

Customize. After that, the shortcut customize window will pop up. 

As you can see, there is a list of shortcuts command that you can 

easily modify, delete or even make a new one over an existing 

one.  
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 If you want to create a new one, just click the New button and the customize 

command window will pop up. Then you can search the command or select 

one from the command list. For example, you can input òcommand lineó and 

then select the requested command. Notice that it will display the command 

properties by selecting the requested command at the right side of the 

window. After selecting the command, press OK. 

Then the set shortcut window will pop up. You can input the desire 

keyword(s). For example, you can set the shortcuts SHIFT+D. If you want to 

delete a created shortcut command, invoke the command CUSTACC and then 

select the delete button from the Shortcut Customize window. 

 

 

 

2.1.4. The Ribbon 

The ribbon consists of several panels, which are organized into each tab according to their task label. The tools and controls in 

each panel are also available in toolbars and dialog boxes.  

  

 

Panel         Tab     Expandable panel       Expandable tools button 

 

Tab: The ribbon is structure by tabs. Every tab 

displays a series of panels with its own tools 

(commands or thumbnails) easier to select or pick. 

 

Panel: The panel shows the most used tools. Some 

thumbnails has an expandable tools button that can 

be expanded in a drop-down method. In addition, 

most of panels at home tab have an expandable 

panel that shows up more commands related.  
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Expandable Panel: The expandable panel is located at the bottom of the panel. If you click at the bottom of 

the panel, more commands related will be displayed. 

Expandable Tools Button: Some thumbnails (tools or commands 

at the panel) have an expandable tools button that can be 

expanded in a drop-down method. If you click this button, all the 

related tools will be displayed.  

2.1.5. Appearance 

You can manage the interfaceõs theme plus show/display toolbars, menu bar, file tabs and status bar.    

  

 

 

  

 

 

 

 

 

2.1.6. Drawing Area 

Your drawings are displayed in the drawing window. 
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2.1.7. Toolbars 

Toolbars partially contain buttons that start commands. When you move your mouse or pointing device over a toolbar button, 

the tooltip displays the name of the button.  

 

 

 

   

The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well 

as Microsoft Office standard commands such as New, Open, and Save. GstarCAD 2025 classic workspace initially displays 

several toolbars by default: 

- Draw toolbar 

- Draw order toolbar 

- Modify toolbar  

- Properties toolbar 

- Layer toolbar 

- Style toolbar 

- Standard toolbar 

2.1.7.1. Displaying and Hiding Toolbars 

GstarCAD 2025 provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can also move 

and dock toolbars. To choose which toolbars to display: 

1.- Execute TOOLBAR command or select the option TOOLBARS from the drop-down list under Appearance button (at top right 

of the interface) to open the Toolbar dialog box. 

2.- Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK. 
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To make floated a horizontal docked toolbar, just click and 

hold the left side of it and drag around the place you need.  

To make floated a vertical docked toolbar, just click and hold 

the top of it and drag around. To dock any toolbar, just double-click at the left side of it.   

 

2.1.7.2. Starting Commands Using Toolbars 

To start a command from a toolbar, click a 

command button and respond to the prompts. 

2.1.8. User Coordinate System (UCS) 

The icon indicates the orientation of the drawing in two dimensional space. 

  

 

 

2.1.9. Model Space and Layout Space tabs 

Click a tab to switch between the drawing of your model and a printed layout.  
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2.1.10. Command Window 

The command bar is a dockable window in which you can type commands and view prompts and other program messages. You 

can move the command bar by dragging it. 

When the command bar is floating, you can drag the top or bottom of the window to change the number of lines of text it 

displays. You can dock the command bar at the top or bottom of the drawing. 

 

  

2.1.10.1. Enter Commands on the Command Line 

Type the full command on the command line and press ENTER or 

SPACEBAR, or right-click on your pointing device to start the command. 

Some commands also have abbreviated names (aliases). 

2.1.10.2. Specify Command Options 

Once you have entered a command on the command line, it 

displays a set of options or a dialog box. To choose a different 

option, enter one of the options in the brackets (either uppercase 

or lowercase letter is OK), and then press ENTER or SPACEBA.

2.1.10.3. Execute, Repeat and Cancel Commands 

 To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names has been 

entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To 

cancel a command in progress, press ESC.

2.1.10.4. Nesting a Command 

To use a command inside an active command, type an apostrophe before you type the command. For example, you turn on the 

object snap while you are drawing a circle, thus you can setup Object snap 

mode before continuing drawing. 

Command: circle> Specify center point for circle or [3P/2P/Ttr (tan tan 

radius)]: 'osnap 

 

(Setup object snap mode as Center in Draft Settings dialog, and then close 

the dialog to go on performing CIRCLE command) 
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2.1.10.5. Enter System Variables on the Command Line 

System variables are available for controlling 

how certain commands work. For example, 

GRIDMODE is used to control the grid status 

ON or OFF. 

2.1.10.6. Using GstarCAD Text Window 

The GstarCAD Text Window displays a history of the 

commands and prompts issued since you started the 

current session of GstarCAD. 

To display or close the GstarCAD Text Window press F2. 

To view entries in the GstarCAD Text Window, just drag the 

scroll bars or use the Up (ŷ) and Down (Ź) arrows to 

display previously used commands. 

2.1.10.7. Switch Dialog Boxes and Command Line 

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the 

command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as 

well: 

-ATTDIA controls whether INSERT uses a dialog box for attribute value entry.                               

-EXPERT controls whether certain warning dialog boxes are displayed.                                        

-FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is set to 1, 

OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command line. Even 

when you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (~) at the first prompt.  

2.1.10.8. Dynamic Input 

"Dynamic input" box is a floating window which appears near the 

cross cursor. It provides a convenient method for users to input 

commands or system variables dynamically and display the 

index information. Type a command using the dynamic input, it 

displays a list of all the commands whose prefix matches what 

you've typed plus it will displays all their icons making easier to 

recognize them at glance. When creating and editing objects, the 

dynamic dimension can guide you draw precisely. What's more, 

the dynamic input displays all options of a command and could 

select them in different methods.  

GstarCAD 2025 supports the functions of Dimension Input, vertical Dynamic Prompts list and independent Pointer Input boxes, 

it provides easier-to-use experience and improves design efficiency.  
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 ̧ Independent Pointer Input Boxes 

Pointer Input boxes for length, angle and coordinates, etc. are displayed independently, making it more convenient for users to 

input different values by simply switching between the boxes using the TAB key.  

 

 

 ̧ Dynamic Dimension Input 

When creating and editing objects, data such as length, angle, radius, etc., are displayed in the form of dimensions, which are 

dynamically changing as the mouse cursor is being moved. With the help of the independent Pointer Input boxes, users are 

now able to input dimension data and execute design operations more efficiently. 

 

 

 

 ̧ Vertical Dynamic Prompts List 

Dynamic Prompts List are now displayed vertically by default in GstarCAD 2025, which allows users to see all the prompts at 

once, it simplifies drawing operations. Horizontal prompts list could still be activated by using system variable DYNLISTSTYLE.  
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2.1.11.  Status Bar 

Display information such as the current cursor coordinates, Snap, Grid, 

Ortho, Polar, Osnap, Otrack and other settings. In addition to displaying 

information, the status bar is a quick way to access many features. You can 

click status bar items to make changes, and right click items to display 

short cut menus that allow you more choices. By default, the status bar is 

shown as the picture below:  

 

The status bar icon also can be show as text button, right click on one of 

the icon of the status bar, uncheck the "Use Icon" option and 

you will get another method to show the status bar. 

  

2.1.12. Properties Palette 

You can modify the value or properties of object(s) you wanted in each column. The Properties palette shows all properties of 

the specified object. When selecting multiple objects, the Properties palette shows the command properties of the selected 

objects. If none of the object is selected, the Properties palette displays the general properties of the current layer, View 

properties as well as the UCS information. By default, double-click an object opens Properties palette if the Properties palette is 

hidden. This operation is not available when the objects are block, hatch pattern, text, multiline, external reference or gradient 

fill. 

  

 

 

 

 

 

 

GstarCAD also supports Quick Properties, which is a set of 

objects properties displayed through the Properties Palette. You 

can customize your own Quick Properties; you can decide to 
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show your preferred object type with selected object properties to save the limited drawing space. You can set the objects 

properties to display in quick properties from CUI. 

 

 

Palette Settings: 

You can click the Properties button or right-click on the Title bar of the palette or window to enable Anchor left/right, Auto-hide 

(There is an Auto-hide button in the Title bar) or adjust the transparency of the floating palettes or windows.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Anchor Left<: Anchors a dockable window or palette to the left of the drawing area. When the cursor is moved on it, the 

anchored palette or window displays with full opaque, when the cursor is moved away, it hides automatically. Also, when an 

anchored window is open, its content overlaps the drawing area.  

Anchor Right>: Anchors a dockable window or palette to the right of the drawing area. When the cursor is moved on it, the 

anchored palette or window displays with full opaque, when the cursor is moved away, it hides automatically. Also, when an 

anchored window is open, its content overlaps the drawing area.  

Auto-hide: A floating window rolls open and closes as the cursor moves across it. When this option is unchecked, the window 

stays open.  

Transparency: Adjusts the level of transparency for the window and on mouse 

over.  

¶  How transparent should the palette be: Sets the transparency of a 

palette while the cursor moves away from the palette. Itõs also controlled by the 

GLOBALOPACITY system variable. 

¶ How transparent should the palette be on mouse-over: Sets the 

transparency of a palette while the cursor moves on the palette. Itõs also 

controlled by the ROLLOVEROPACITY system variable. 

¶ Click to Preview button: Press the button, it displays the transparency of 

palette while the cursor moves away from the palette, release the button, it displays the transparency of a palette while the 

cursor moves on the palette. 
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¶ Apply these settings to all palettes: Applies transparency settings to all palettes. Itõs also controlled by the 

APPLYGLOBALOPACITIES system variable.  

¶ Disable all window transparency(global): Controls whether palettes can be adjusted transparency. Itõs also controlled by 

the PALETTEOPAQUE system variable. 

2.1.13. NAVICUBE  

The NaviCube is a navigation tool that is displayed when you are working in 2D model space or 3D visual style, which allows 

switching between standard and isometric views easier. It consists of a cube, compass and options, is draggable and clickable, 

and supports switching to any available preset views, rolling the current view, or setting the current view as the Home view.  

You can enter the NAVICUBE command, or click RibbonView 3D Tool NaviCube to control whether to display the 

NaviCube in the drawing area. When the value is ON, the NaviCube is displayed, when the value is OFF, the NaviCube 

disappears. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Appearance of the NaviCube: The NaviCube is displayed in one of two 

states: inactive and active. When your cursor is not touching the 

NaviCube, itõs inactive, it appears partially transparent by default so that 

it does not obscure the view of the model. When you move the cursor 

over it, it becomes active, it is opaque, so the view of the objects in the 

current view of the model may be obscured. And you can other 

properties of the NaviCube within the Settings option. 
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Cube:  It is in the top right corners of the 

drawing area over the model, and shows the 

current viewpoint of the model. When moving 

the cursor over it, you are able to click the 

faces, corners or edges to change the views 

conveniently, as well as click on the cube and 

drag it to roll the current view.  

 

 

 

 

 

Compass: The compass is displayed below the NaviCube 

and indicates the north direction defined for the model. You 

can click any of the directional letters on the compass to 

rotate the model. 

 

 

 

 

 

When the view is òFrontò òBackó óLeftó or óRightó, some little triangle buttons will display around the cube, which allow you to 

switch between adjacent views by clicking them. 

 

ü When clicking the triangle button at the right or left side, the view is switched to its right or left adjacent view. So, you 

can continuously switch between different views and rotate the navigation cube horizontally by clicking these two 

buttons.  
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ü When clicking the triangle button at the top or bottom side, the view is switched to 

top or bottom view. The top and bottom triangle buttons can only be clicked once. 

 

 

 

ü When clicking the triangle button at corners, the view is switched to the edge view 

of two adjacent views. The corner triangle buttons can only be clicked once. 

 

 

   

Options Menu: 

ü Home: Changes to Home view 

ü NaviCube Settings: Opens NaviCube Setting window 

¶ On-screen: Identifies the in the viewport where the NaviCube is displayed. 

¶ Navicube size: Specifies the size of the NaviCube. 

¶ Inactive Opacity: Controls the opacity of the NaviCube when inactive. 

¶ Show UCS Menu: Controls the display of the UCS drop-down menu. 

¶ Zooms to extents after view change: Specifies if the model is forced to fit the current viewport after a view change. 

¶ Orient Navicube to current UCS: Controls whether the NaviCube reflects the current USC or WCS. 

¶ Show compass below the Navicube: Controls the whether the compass is displayed below the NaviCube tool. 

¶ Restore Default: Restore NaviCube settings to default values. 

ü 3D views: Displays view control list. 

ü Coordinated system: Controls coordinate system. 

ü Upside down: Changes to the view side which is parallel to the current view side. 

ü 90£Clockwise: Rotates 90 degrees clockwise. 

ü 90£Counter Clockwise: Rotates 90 degrees counterclockwise. 
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Right-click Menu:  

ü Home: Goes back to Home view 

ü Set Current View as Home: Specifies the current view as the 

Home view. 

ü NaviCube Settings: Opens the NaviCube Setting window. 

ü Help: Open Online Help system, Home ð Commands ð N ð 

NAVICUBE command. 

 

 

2.1.14. Lasso Selection 

The Lasso selection allows you to create an irregularly shaped window or crossing selection set. The implementation of lasso 

selection can not only replace frame selection to select simple objects, but also solve the problem of difficult selection of some 

complex objects using frame selection. 

To use the lasso selection, just hold the mouse button down while dragging the mouse to create the lasso. When you release 

the mouse button, the lasso is completed. 

2.1.14.1. Lasso Selection Modes 

Lasso selection provides three modes: Window Lasso, Crossing lasso and Fence lasso, you can press the spacebar to cycle 

through the lasso modes. 

ü Window Lasso Selection: Hold the mouse button down and drag the mouse from left to right, only the objects that are 

completely enclosed in the selection area are selected. 
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ü Crossing lasso selection: Hold the mouse button down and drag the mouse from right to left, the objects enclosed in and 

that are crossed by the selection area are selected.  

 

 

 

 

 

 

 

 

 

 

 

 

ü Fence Lasso Selection: Specify points to define a fence, the objects that pass through the fence will be selected. 

 

 

2.1.14.2. System Variable Compatibility 

GstarCAD optimizes the PICKAUTO system variable to be consistent with ACAD. 

System Variable Description Value Value Description 

PICKAUTO 

Used in conjunction with lasso 

selection to control the automatic 

windowing for object selection. This 

system variable is also used to control 

the opening and closing of the lasso. 

 

-7 ~ 

-1 

Selects an object by clicking. It only 

stores the value and the value will 

not take effect. 

0 

Selects an object by clicking. Turns 

off automatic window and crossing 

selection. 

1 

Starts a window or crossing 

selection if the cursor is not directly 

over an object when clicking; 
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Selects an object directly by 

clicking if the cursor is on the 

object, selection complete. 

2 

Starts a window or crossing 

selection even if the cursor is 

directly over an object.  

4 

Starts a window or crossing lasso 

selection if the cursor is not 

directly over an object when 

clicking; 

Selects an object directly by 

clicking and dragging if the cursor 

is on the object, selection 

complete. 

Note: To specify more than one option, enter the sum of their values. For example, entering 5 specifies the bitcode 1 and 4 

options. 

Value 

Description 

 

3 The combination of bitcode 1 and bitcode 2 which has the same effect as bitcode 2 

5 The combination of bitcode 1 and bitcode 4 which has the same effect as bitcode 4 

6 The combination of bitcode 2 and bitcode 4 

7 The combination of bitcode 1, 2 and 3 which has the same effect as bitcode 6 

 

Summary: 

ü When the value of PICKAUTO is 0, the objects can be selected only by clicking.  

ü When the value is 1, 2 or 3, itõs window selection.  

ü When the value is 4, 5, 6 or 7, itõs the window selection and crossing lasso selection (To specify a window selection area, 

click and release the left mouse button, move the cursor, and click again to finish; To create a lasso selection, click, drag, 

then release the left mouse button to finish). 
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2.2. Customize the Drawing Environment 

In GstarCAD 2025, there are different elements of the working environment that can be customized to fit your needs. 

2.2.1. Set Interface Options 

 In the Options dialog box, you can change many of the settings that affect the interface and drawing environment. 

 

 

 

 

 

 

2.2.2. Settings of Modifying Interface

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog 

box, Open and Save tab, select Automatic Save and enter the interval in minutes. 
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Color (Display tab): Specify the background colors used in the layout and Model tabs and the color used for prompts and 

crosshair.                                                                                 

Font (Display tab): Change the fonts used in the window and in the text window. This setting does not affect the text in your 

drawings.  

Search Path (Files tab): Set the search path to find drawing support files such as text fonts, drawings, linetypes, and hatch 

patterns. 

 

 

 

 

 

 

 

2.2.3. Save and Restore Profiles 

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled. By 

default, your current options are stored in a profile named Default. The current profile name, as well as the current drawing 

name, is displayed in the Options dialog box. 

GstarCAD 2025 stores the profile information in the system registry and saves it as a text file (an ARG file) and also organizes 

essential data and maintains changes in the registry as required. If you make changes to your current profile during a session 

and you want to save those changes in the ARG file, you must export the profile. When you export the profile with the current 

profile name, GstarCAD updates the ARG file with the new settings. You can re-import the profile to update your profile setting
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2.2.3.1. MOVEBAK Command 

The new MOVEBAK command changes the destination folder for drawing backup (BAK) files. Once you specify a path, the 

drawingõs BAK files is placed in that path after every save operation. 

Enter new value for MOVEBAK, or for none <current setting>: 

Enter a . (Period) for none or type the folder name 

If you enter ".", the MOVEBAK folder name is cleared and new BAK files will be created in the original folder. 

 

2.3. Customize User Interface 

Drag & Drop Customization: An innovative way to customize user interface must be easy and quickly according to user needs, 

so this is possible by drag and drop action, that means users can drag any command from the command list and drop it into 

workspaces elements like ribbon panels and toolbars that are visible at top right corner of the CUI dialog box. Users will not 

have restrictions to place anywhere or even arrange a preferred command on a panel or toolbar. UI customization has never 

been easier and flexible through Drag & Drop action. 
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Brief introduction of CUI dialog box: 

1. CUI dialog box: Now the CUI dialog box is divided into three tabs: Elements Customization, Workspace Customization and 

Transfer tab in which the main attraction is the Elements Customization tab through its new way of customization (Drag & Drop).  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Right click menu: Context menu is available for different interface element as shown below:  

 

 

 

 

 

 

 

 

 

 

 

 

3.  Find command: There are several methods to quickly find out the command you want, with these methods, you never need 

to browse the command from the top of the list until the end which greatly enhance your work efficiency. 

 

 

 

 

 

 

 

 

 

 

 

 



Chapter 2_Starting up GstarCAD 2025 

 

27 

1- Filter the command by Category: Click the button right side and select the category the 

command belongs which will reduce the command search scope  

 

2-Filter a command by entry relevant keywords: For example, input òdimensionó in the filter, all 

the commands contains the word òdimensionó will be shown, reducing the number of 

commands to browse. 

 

 

 

 

 

 

 

 

3- Command cleaner: If you input the keywords in the filter, the icon will automatically change to   which is used 

to clean the content in the filter, meanwhile, the following command list will return to the default state. 

 4- Find and replace: In Find tab input the command you want to find out and click Find Next, the command you searched will 

be positioned accurately. In replace tab, you can replace one command with another command, but we suggest not change the 

standard command name and description. 

 

 

 

 

 

 

 

 

 

5- Create a new command: If it is necessary to add secondary development program command to the command list, you can 

set the items follow the current command settings as shown below. 
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Restore and reset: 

If all the customization operation has been finished, but you made some mistakes 

when customizing CUI or you are not satisfied with the effect, restore and reset can 

help you recover to the original settings. 

Restore̔ Restore the backup Settings, click "Apply" button, the data before 

modifying will be saved as backup files which are used for recovery. 

Reset̔ Recover to the initial setting when first installing GstarCAD.  

 

 

2.4. Import, Export and Migrate User Custom Settings 

GstarCAD 2025 supports importing and exporting the settings of current version, as well as importing settings of old version, 

which enable users to avoid repeating same settings when they install the software. Users can also import Tool Palettes from 

AutoCAD. 

 

 

 

 

 

 

 

 

 

 

 

2.4.1. Import and Export Settings of Current Version 

You can import and export of settings of current version in the WINDOWS Start menu without starting GstarCAD, which makes 

the operation more convenient and simpler. And, importing the saved exported settings when the software is reinstalled or 

Installed on other machines will save plenty of time. 

         

 

 

 

 

 

  



Chapter 2_Starting up GstarCAD 2025 

 

29 

Export Settings of current version: Open windows start menu, find your Gstarsoft item and click òExport the settings of current 

versionó, choose the location you prefer to save the ò.cfgbakó file and save it.  

 

 

 

 

 

 

 

 

Import Settings of current version: Open windows start menu, find your Gstarsoft item and click òImport the settings of current 

versionó, find the ò.cfgbakó file and open it.  

 

 

 

 

 

 

     

 

 

 

 

 

 

Exported Settings includes:  

ü Options: File locations, Display options, User preferences, Drafting settings, Selection settings and other custom settings 

ü Customize User Interface: Workspace, toolbars, ribbon customization, command, keyboard and mouse button 

customizations 

ü Alias file (gacd.pgp) 

ü Printer support file 

ü Hatch pattern (*.pat) 

ü Tool Palettes 

ü Template file (*.dwt) 

ü Fonts and shapes (*.shx) 

ü Line type (*.lin) 

ü Font mapping file (gacd.fmp) 
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2.4.2. Reset Settings to Default 

In GstarCAD 2025, you are able to reset GstarCAD settings to default by clicking Windows Start menuGstarCAD 2025

Reset Settings to Default.  

 

 

 

 

 

 

 

 

 

You can only reset the settings when the software is closed.  

 

If the software is closed, the Reset Settings dialog box will pop up, you can select ôBack up and reset custom settingsõ option to 

create a backup file that contains your customized files before resetting the product. Or, you can select ôReset custom settingsõ 

option to reset the product without creating backup files of your custom settings. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  

¶ Resetting the custom settings actually is cleaning up the registry information of GstarCAD software and deleting the 

Local folder and Roaming folder. After starting GstarCAD again, the new Local and Roaming folder will be 

regenerated. 

¶ Backing up and resetting the custom settings actually is cleaning up the registry information of GstarCAD software 

and backing up the Local folder and Roaming folder under C:\Users\username\AppData, and then deleting the Local 

folder and Roaming folder. After starting GstarCAD again, the new Local and Roaming folder will be regenerated. 
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2.4.3. Migrate from a Previous Release 

GstarCAD 2025 adds a "Migrate from a previous release" feature in the WINDOWS Start menu program items, which allows 

users to migrate selected settings of old versions directly to the new version after installation without copying and setup 

manually under same language. The earliest version that can be migrated is GstarCAD 2016. 

 

Migrated Settings includes:  

ü Options: File locations, Display options, User preferences, Drafting 

settings, Selection settings and other custom settings 

ü Customize User Interface: Workspace, toolbars, ribbon 

customization, command, keyboard and mouse button 

customizations 

ü Alias file (gacd.pgp) 

ü Printer support file 

ü Hatch pattern (*.pat) 

ü Tool Palettes 

ü Template file (*.dwt) 

ü Fonts and shapes (*.shx) 

ü Line type (*.lin) 

ü Font mapping file (gacd.fmp) 

 

Note: 

ü After migration from older version, the relevant settings of current version will be overwritten, and canõt be restored.  

ü After migration from older version, the new functionalities that only current version supports, will be reset to default. 

 

2.4.4. Import AutoCAD Tool Palettes  

You can import AutoCAD customized Tool palettes in the WINDOWS Start menu easily. If you installed AutoCAD in your PC, you 

can just import the file from the path in AutoCAD options. If you need to import AutoCAD customized Tool Palettes from another 

equipment, the path can be anywhere, but the folder must include AcTpCatalog.atc file. 

 

 

 

 

Before importing an AutoCAD tool palettes, read carefully the following notes:  

 

1. The default blocks of AutoCAD cannot be directly imported into GstarCAD. If you want to import default blocks of AutoCAD to 

GstarCAD, you need to drag them to the drawing from the Tool Palettes, and add them back to Tool Palettes in AutoCAD, then 

save the drawing and import. 

2. The imported file is only block and command, hatch pattern, light source, constraint, table and other objects havenõt been 

supported yet. 

3. If there is a lack of grip point in the imported dynamic block, probably itõs the result of the imperfect action of the dynamic 
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block. 

4. All eligible GstarCAD paths will be detected first when you import the file into GstarCAD directly, the entire Tool Palettes in 

GstarCAD will be overwritten. 

5. The order of the tools list in Tool Palettes after import may be different from that of AutoCAD. The reason is that AutoCAD 

supports a file recording the order of the tools in Tool Palettes, but GstarCAD does not. 

6. If the source DWG drawing location is changed before you import custom AutoCAD Tool Palettes and its tools, the block(s) 

imported into the palettes in GstarCAD will be unable to be used without that corresponding DWG drawing original saved path.  

2.5. Tool Palettes 

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool 

palette are called tools. You can create a tool by dragging an object onto the tool palette. In 

GstarCAD, blocks and external references (xrefs) can be dragged onto the tool palette. The new 

tool inserted will has the same properties into your drawing. Also you can close,create, 

customize the paletts by doing right click on it. To open the tool palettes just press CTRL+3 or 

Type TOOLPALETTES command. 

 

 

 

 

2.6. Design Center 

With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents: 

-Browse for drawing content on your 

computer or a networked drive.                                                        

-View definition tables for named objects 

and then insert, attach, copy and paste the 

definitions into the current drawing.                                                               

-Create shortcuts to drawings and folders 

that you access frequently.                                                    

-Add content such as xrefs, blocks to a 

drawing.                                                        
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-Drag drawings, blocks to a tool palette for convenient access 

Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and 

related support files, Xrefs, layouts and named objects, including blocks, layers, linetypes, text styles and dimension styles 

within a drawing. 

Open Drawings: A list of currently opened drawings is displayed. If you click a drawing file and then click one of the definition 

tables, you can load the content into the content area.                                                             

History: A list of previously opened files is displayed. If you double-click a drawing file from the list, you can load the content 

into the content area. 

Favorites: If you have contents need to access quickly on a regular basis, the Design Center provides a solution to finding those. 

When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you can save 

shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you create are 

stored in the Favorites folder. 

2.7. Clean Screen 

Now, if users want to maximize drawing space, they can press the keywords Ctrl+0 or select the icon (Clean Screen) located in 

the right corner of the status bar. After executing this command, Toolbars and dockable windows (excluding the main menu bar, 

command line and status bar)will automatically be cleaned. This function can provides better visibility as large as possible to 

make it easier to fully understand every details of the drawing. 

 

 

 

 

 

 

 

 

 

 

 

 

2.8. Lock UI 

Lock UI locks the position and size of toolbars and dockable windows such as Design Center, Properties palette, etc. To unlock 

them temporarily, hold down CTRL key. LockUI setting is stored as a bit code using the sun of the following values: 

0 Toolbars and windows not locked 

1 Docked toolbars locked 

2 Docked or anchored windows locked 

4 Floating toolbars locked 

8 Floating windows locked 
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3. Create, Open, Save, Recover a Drawing and Manage Drawings 

3.1. Create a Drawing 

3.1.1.  Create a New Drawing Using Default Settings 

When the system variables FILEDIA and STARTUP are set to 1, 

typing NEW at the command bar, it opens Startup dialog box, from 

which you can use Default Setting, Template or Wizard to create a 

new drawing. 

You can select either imperial or metric units for the new drawing. 

Imperial measurement system: The drawing uses internal default 

values with default boundary is 12 ×  9 inches. 

Metric measurement system: The drawing uses internal default 

values with default boundary is 429 ×  297 millimeters. 

 

3.1.2. Create a New Drawing Using a Setup Wizard 

From the Startup dialog box, you can select "Use a Wizard" tab to 

create a new drawing by the wizard. There are two wizard options 

illuminated as follows: 

Advanced Setup Wizard: 

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings 

such as units of measurement style, precision, direction, and orientation based on template gcadiso.dwt. 
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Quick Setup Wizard: From this option, you can specify units of measurement, 

precision of displayed units, and grid limits based on template gcadiso.dwt. 

 

 

3.1.3. Create a New Drawing Using Template 

When you need to create several drawings with the 

default settings, you can save time by creating a 

template file designed to create the same drawing files 

so that you does not need to specify default settings 

each time you start. Conventions and settings commonly 

stored in template files include: unit type and precision, 

title blocks, borders, and logos, layer names, snap, grid, 

and ortho settings, grid limits, dimension styles, text 

styles and Linetypes.  

Also when the system variables FILEDIA and STARTUP 

are set to 1 and 0 separately, typing NEW opens Select Template dialog box, from which you can select the desired one or use 

the default template by clicking the arrowhead button next to the Open button. 

 

3.2.  Open a Drawing 

3.2.1. Open a Drawing 

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, 

drawing standard (dws) files and drawing template (.dwt) files. You can also 

open and check drawings that you suspect are damaged.  

 

To open an existing drawing:  File > Open     

Command line> OPEN     Using shortcut> 

CTRL+O 

-In the dialog box, choose the type of file you 

want to open. 

-Choose the folder containing the desired 

file.-Choose the drawing you want to open, and 
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then click the Open button or Double click on the drawing you want to open.  

3.2.2. Multiple Open Drawings 

You can open multiple drawings at one time. There are several methods for switching a drawing to another. 

- Acting the drawing by clicking it or using shortcut keys of <Ctrl+Tab>.                                                   

- You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use 

Arrange Icons to align icons if there are several minimum drawings. 

 

 

 

  

  

 

3.3. Save a Drawing 

3.3.1. Save a Drawing 

You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In 

addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created 

your drawing using a template, saving the drawing does not alter the original template. 

To save a drawing:  File > Save     Command line> SAVE     Using shortcut> CTRL+S 
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Remark: When you save a drawing the first time, the program displays the Save 

Drawing As dialog box so that you can choose a directory and type a name for the 

drawing. 

3.3.2.  Save Your Drawing Automatically 

You can specify to save drawing files automatically in order to minimize the lost data 

once a problem occurs. 

If you start the automatic save option, your drawing is saved at specified time 

intervals. By default, system assigned the name filename. sv$ for temporarily saved 

files, filename here refers to current drawing name.  

 

 

 

3.3.3. Save Part of a Drawing File 

You can use BLOCK command or WBLOCK command to create a new 

drawing from part of an existing drawing. You can select entities or a 

block definition in your current drawing and save them in a new 

drawing file. The description also can be saved in the new drawing. 

 

 

3.3.4. Save to a Different Type of Drawing File 

 Choose the format from Save as Type in the Save Drawing As dialog box, you can save a drawing to an earlier version of the 

drawing format (DWG) or drawing interchange format 

(DXF), or save a drawing as a template file. 

To save a different format:   

File > Save As Command line> SAVE AS     

Using shortcut> SHIFT+CTRL+S  
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3.3.5. DWG Convert 

DWGCONVERT command converts one or a bunch of selected drawing files to another dwg version available. The newly 

generated file can overwrite the original one, and it can also be compressed into a self-extracting EXE file or a ZIP file to 

facilitate batch format conversion of the entire project drawing. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.3.6. Batch conversion between graphical file formats 

Converts one or a bunch of selected drawing files 

to an older or current dwg version available. The 

newly generated file can overwrite the original file, 

and it can also be compressed into a 

self-extracting EXE file or a ZIP file to facilitate 

batch format conversion of the entire project 

drawing. 

 

Steps to Convert DWG files to different format 

1. Click òFileó>òDWG Convertó in turn 

2. Click òDWG Convertó dialog box >òAdd Fileó (Near the bottom) 

3. In òSelect Fileó dialog box, you need to browse to the folder where the graphics file is to be converted. 

4. Click the graphic file name, and then click òOpenó. 

5. In òDWG Convertó dialog box, click òConversion Setupsó. In òDWG Convertó dialog box, create a new Conversion Setup 

(NEW), modify existing Conversion Setup (MODIFY) or select a previous Conversion Setup, and then click òCLOSEó. 

6. In òDWG Convertó dialog box, click òCONVERTó. 

7. If the Conversion Setups specify an EXE or ZIP file, browse to the desired destination folder, then double-click the file to 

select it. If needed, input a new name for the file. 

8. Click òSAVEó. 
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3.3.7. Use Backup Files 

 GstarCAD creates a backup file with the current drawing name and a 

".bak" extension to save the previous version of the current drawing 

when launching "backup automatically" option. 

3.3.8. Reduce the Time Required to Save a Drawing File 

In order to reduce the time of saving a drawing file, you can specify the 

incremental save percentage on the Open and Save tab of Options 

dialog box or from the ISAVEPERCENT system variable. 

 The incremental save updates only the portions of the saved drawing file you changed. 

Drawing files will contain a percentage of potentially wasted space when you use 

incremental saves. This percentage increases after each incremental save until it reaches 

the specified maximum value, and then a full save is perform.  

3.4. Recover a Drawing 

3.4.1. Recover a Damaged File 

You can recover some or all of data by reverting to a backup file or using commands to find and correct errors if a drawing file 

is damaged. A drawing file may be damaged by a hardware failure, power outage and system crash. You had better create a 

backup file if the drawing is important.  

In the Open and Save tab of Options dialog box, you can specify the backup file are created when you save drawings and set the 

proper interval time for saving. Then a backup copy file with a ".bak" extension is created when you save the named drawing 

once again. After that, a backup file is always updated while you executing the command SAVE or SAVEAS. 

You can use RECOVER command to check and attempt to open a damage file. Then uses AUDIT command to find and correct 

errors. 

To open a damaged file:  File > Drawing Utilities> Recover      

Command line>RECOVER  
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-In the dialog box at Files of Type, choose the type of file you want to recover.                                                        

-Choose the directory containing the damaged file.                                                     

-Choose the damaged file you want to recover and Click the Open button or Double click on the drawing you want to open. 

To check errors for a drawing file:  File > Drawing Utilities> Audit     Command line> Audit 

 

 

 

 

 

 

 

  

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit 

2. Input Y or N to determine whether to recover the errors that are automatically found by GstarCAD, and then press Enter. 

 

3.4.2. Drawing Recovery Manager 

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened 

drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files 

that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup 

File list on the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing in process of 

backup. 

When program or system stopped by accident, the drawing files need to recover are sorted 

into the following types. 

-Recovered drawing file saved when program fails (DWG)                                                  

-Temporary saved file (sv$)                                                                  

-Backup file (BAK)                                                                           

-Source drawing file (DWG)  
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3.5. Manage Drawings 

In GstarCAD the Sheet Set Manager allows you to manage the entire project 

drawing sheetsets. It can manage all the work flow from sheets creation, 

printing and publishing.etc.  

 

In Sheet Set Manager, a sheet set is an organized collection of sheets from 

several drawing files and each sheet in a sheet set is a layout in a drawing 

file. 

Begin taking advantage of sheet set functionality for your current projects with minimal effort by importing your current drawing 

layouts into a sheet set. You can easily open drawings from a central location while you continue edit them using traditional 

tools.  

3.5.1. Sheet Set Control 

Lists menu options to create a new sheet set, open an existing sheet set, or switch between open sheet sets. 

 

 

 

 

 

 

 

 

 

 

 

 

Details or Preview: Displays either descriptive information or a 

thumbnail preview of the currently selected item in the tree 

view. 

  

 

 

 

 

 

 

 

Tree View: Displays the contents of the sheet list. 
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You can use the following actions in the tree view: 

¶ Right-click to access shortcut menus of the operations that are relevant to the 

currently selected item. 

 

 

 

¶ Double-click items to open them. This is a convenient method for opening drawing files from the Sheet List. You can also 

double-click items in the tree view to expand or collapse them. 

 

 

 

 

 

 

 

 

 

 

¶ Click one or more items to select them for operations such as opening, publishing, or transmitting. 

 

 

 

 

  

 

 

 

¶ Move the cursor over a single item to display descriptive information or a thumbnail preview of a selected sheet, view, or 

drawing file. 

 

 

 

 

 

 

 

 

¶ Drag items within the tree view to reorder them. 
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3.5.2. Sheet Set Manager Basic Information  

Opening Sheet Set Manager  

Ribbon: View tab > Palettes > Sheet Set Manager or Type: sheetset  

 

 

 

Creating a Sheet Set  

Once the Sheet Set Manager is open, select the pull down box at the 

top and then click on New Sheet Set. 

 

A new dialog box will pop up displaying the 4 steps in creating a Sheet 

Set.  

 

 

Begin 

Under Begin there are two options for creating a sheet set.  

Option one  

Is using òAn example sheet setó that allows the use of a standard 

template to create the sheet set.  

Option two  

Is using Existing drawings to start a new sheet set. We are going to 

select the Existing Drawings option.  

Sheet Set Details 

This is where basic information like sheet set name, description, and file location can be added.  
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Choose Layouts  

Existing layouts can be added to the sheet 

set by browsing for the proper file needed 

in the drawing set. Once the layouts are 

selected, click Next to confirm. 

 

 

 

 

 

 

Confirm  

The confirm tab will give a summary of 

the layouts to be added to the set. After 

selecting the Next button the new layout 

will be added to the sheet set.  

 

 

 

 

Import layouts to the Sheet Set Manager 

To add a new sheet from an existing drawing layout, right click the title of the sheet 

set and select Import Layout as Sheet. A new pop up box will appear which allows you 

to browse for an existing drawing to add a layout. 

 

 

 

 

 

Tip: If the import box is not checked, the layout is already in the sheet set or the 

layout is unable to be imported into the set. 

 

 

 

 

Managing Sheet Set  

Moving and Removing Sheets from a set  

Once the sheets have been added to the Sheet Set Manger, they can be 

dragged and dropped to the order needed. To remove a sheet from the 

set, right click and select Remove Sheet. 
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Rename and Renumbering Sheets 

To rename and renumber a sheet or a subset, right click on the 

sheet needed to be changed and select Rename & Renumber. 

 

A pop up box will show up that will allow the number, sheet title 

and layout name to be changed.  

 

 

Adding project information to a sheet set 

To add project information to the sheet set, like 

project name, project number, and project 

description, right click on the sheet set title and 

scroll down to the sheet set Properties. A new pop 

up box will display that allows the update of project 

information.  

Tips: Project information in the sheet set can be 

used in object such as fields 

 

 

 

 

 

Creating Subsets in Sheet Set Manager  

Creating subsets in Sheet Set Manager is a fast way to organize and find what is 

needed in a big drawing set. To create a subset, right click on the sheet set 

and then to New Subset. 

 

 

 

 

 

 

The Subset Properties box will pop up. 

Most of the properties are basic. 

Select OK.  

A new subset is added to the sheet set 

manager. 

Tip: To move a sheet to the new subset, 

simply click and drag to the desired 

subset. 
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Publishing Sheet Sets 

Sheet Set Manager makes it simple to publish a full set or only select sheets of the construction documents. There are two 

ways to plot: Publish directly to the plotter/file or use the Publish dialog box. 

 

Publish and Plot directly to the plotter/file 

Right click on the sheet set, scroll to Publish, and then Publish to Plotter. 

 

This method is used to plot and publish when the page setup is set per layout. The drawback to using this optio

n is if someone plots one of the sheets using the plot command and saved the setup to the layout, the layout w

ill not publish properly. Sheetset can also be packaged and shared through e-transmit. 

  

 

 

 

 

 

 

 

 

 

 

 

Publishing using Publish dialog box may not be as fast as Publishing directly to the plotter/file, but there is less 

of a chance the document will come out wrong.  

 

You are also able to use Page Setups saved in the

 drawing to particular sheets or the full set.  

To pull up the dialog box, right click the Sheet Set

 title, scroll to Publish, and then to Publish Dialog 

Box. The Publish Dialog Box will display.  

 

Now with page setups, Publish Dialog Box can chan

ge the way the document is published. Now we hav

e the options to publish to Plotter named in Page 

Setup, DWF, DWFx, and PDF. 

Selecting the Sheet Set Publish Options allows the 

options to change information like default output location 

and naming.  
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Tip: One of the major options I change the most is type. Multi-sheet file will place the full set in one file and the Single-sheet 

file will place each sheet per file. 
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4. Control the Drawing Views 

4.1. Redraw and Regenerate a Drawing 

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by 

refreshing, or redrawing, the display. 

To redraw (refresh) the current window display:  View > Redraw     Command line> REDRAW 

To regenerate the current window:  View > Regen     Command line> REGEN 

 

 

 

 

 

 

 

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision. 

Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the 

appropriate screen coordinates. 

 

 

4.2. Magnify a View (Zoom) 

You can use ZOOM command to zoom in or zoom out the 

drawing view to meet your need. You can change the 

magnification of your drawing at any time. The cursor 

changes to a magnifying glass when a zoom tool is active. 

Zoom out to reduce the magnification so you can see more 

of the drawing, or zoom in to increase the magnification so 

you can see a portion of the drawing in greater detail. 

Remark: If you are working in a layout viewport and cannot zoom, the layout viewport may be locked. The scale and view do not 

change in model space while panning or zooming in a locked layout viewport. 
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4.2.1. Zooming Methods 

To zoom, you can use any of the following methods: 

-To define the portion of the drawing to zoom, create a window.                                                          

-To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.                                                 

-If you have a mouse with a wheel, rotate the wheel to zoom in and out. 

4.2.2. Zoom to Magnify a Specified Rectangular Area 

You can specify a rectangular area defined by two corners to display the objects within that area as large as possibly. The 

lower-left corner of the specified area becomes the lower-left corner of the new view. 

To zoom in to an area using a window:  View > Zoom> Window     Command line> ZOOM 

-Choose View > Zoom > Window                                                                

-Select one corner of the window around the area you want to magnify.                                                   

-Specify the opposite corner of the window around the area you want to magnify. 

 

 

  

 

 

 

 

 

4.2.3. Zoom in Real Time 

Realtime option zooms dynamically by moving your pointing device up or 

down. By right-clicking, you can display a shortcut menu with additional 

viewing options. 

To zoom in real time:  View > Zoom>Realtime             

Command line> RTZOOM  
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-Choose View > Zoom > Realtime from the main menu.                                                               

-Hold the left mouse button, then drag the cursor forward to zoom in and move back to zoom out. 

4.2.4. Displaying the Previous View of a Drawing 

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire 

drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps 

back through up to 25 successive zoomed or panned views. 

4.2.5. Zooming to a Specific Scale 

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of 

the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at 

the center of the current viewport remains centered on the screen. 

To zoom to a specific scale relative to the current display: View > Zoom>Scale        Command line> ZOOM 

-Choose View > Zoom > Scale from the main menu.                                                                      

-On the Zoom toolbar, click the Zoom Scale.                                                                         

-Type ZOOM in the command line, choose the Scale option, and then press Enter.                                        

-Type the scale factor, followed by an x (such as 2x).                                                           

-Press Enter. 

 

 

 

 

 

 

 

 

 

4.2.6. Displaying the Entire Drawing 

ZOOM Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display 

the objects on layers that are turned off but do not include objects on frozen layers. 
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ZOOM All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger. 

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar 

displays the drawing to its extents, making the image fill the display to the greatest possible magnification. 

4.3. Pan and View 

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing 

horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space. The 

only change is the portion of the drawing displayed. To pan, you can use any of the following methods: 

-For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting 

point of the pan. The second point indicates the amount of pan displacement relative to the first point.-To pan in real time, use 

the Pan Realtime tool on the Standard toolbar.                                                         

-If you have a mouse with a wheel, press and hold the wheel, and then move the mouse. 

To pan in real time:  View > Pan> Realtime     Command line>PAN 

-Choose View > Zoom > Realtime from the main menu.                                                     

-Move the cursor in the direction you want to pan.                                                                  

-To stop panning, press Enter, ESC or choose Exit from the shortcut menu. 

To pan using a mouse with a wheel:  

-Press and hold the wheel, and then move the mouse in the direction you 

want to pan (The MBUTTONPAN system variable controls this feature.) 

4.4. Display Multiple Views on Model Space 

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can 

divide one window into multiple windows. You can also open and display multiple drawings. 

4.4.1. Set Model Space Viewports 

The viewports created on the Model tab completely fill the drawing area and do not overlap. As you make changes in one 

viewport, the others are updated simultaneously. 

You can do the following operations at the model 

space viewport: 

-Set Snap, Grid, and UCS icon modes; Pan; Zoom; 

and restore named views.                                                 

-Save orientations of UCS with individual viewports.                                                    

-When executing a command, you can draw from 

one viewport to another.                                                
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-Name a viewport arrangement in order to you can reuse it on the Model tab or insert it on a layout tab.                        

-When you work on 3D models, is helpful setting up different UCS in individual viewports. 

4.4.2. VPMAX/VPMIN 

VPMAX allows you to expand the current layout viewports and switch to Model Space for editing without worrying about 

messing up viewportsõ scales and limits, while VPMIN allows you to restore the current layout viewport.  

System Variable Description Value Value Description 

VPMAXIMIZEDSTATE 

Controls whether to maximize the current 

viewport (read-only) 

0 Do not maximize 

1 Maximize 

 

4.4.2.1. VPMAX 

Expands the current layout viewports to fill the screen and switches to Model Space for editing. 

You can enter the viewport maximized state in the following four ways: 

ü Enter the VPMAX command in the Layout Space, and then click to select the viewport to be maximized; (when there 

is only one viewport in the layout, the viewport will be maximized directly without the need to select) 

ü Enter the VPMAX command after selecting a viewport in the layout space; 

ü Double-click the viewport border in the Layout Space; 

ü Click the maximize viewport icon on the status bar in the Layout Space. 

 

4.4.2.2. VPMIN 

Exits the maximized state and returns to the current Layout Space. 

You can exit the viewport maximized state in the following three ways: 
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ü Enter the VPMIN command; 

ü Double-click the blue border line; 

ü Click the minimize viewport icon on the status bar in the Layout Space. 

4.4.3. Working with Multiple Views of a Single Drawing 

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple 

windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the 

display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others. 

And also you can switch from one window to another at any time. 

To create multiple views: View > Viewports     Command line> VPORTS 

-Choose View> Viewports-In viewports menu, choose 1, 2, 3, or 4 viewports.                                                    

-Type h if you want the horizontal orientation, or type v if you want the vertical orientation. 

To join two views:  View > Viewports> Join     Command line> VPORTS 

-Choose View > Viewports > Join -Click anywhere inside the window you want to keep.                                                                     

-Click anywhere inside the adjacent window you want to join to the first window. 

To restore a named window configuration: 

-Type -VPORTS system variable at the command line and press ENTER.                                                                                

-Then type Restore.                                                                                

-Then type the name of the window configuration you want to restore. 
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4.4.3.1. VPSCALE 

The VPSCALE (viewport scale) command reports the real scale of the current viewport of a selected layout viewport. 

1. You can open a recent drawing with layouts or create a new viewport on layout space with a desire scale according to paper 

format. 

2. Type VPSCALE command on the command line, and then select the edge of the viewport. 

3. The command line will show the correct viewport scale according to unit measure you are working with. 

4. Notice the status bar shows the right scale of the selected viewport only at layout space. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.4.4. Working with Multiple Drawings 

With the multiple document interface, you can open and work on several drawings at one time, you can copy, cut, or paste an 

entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages: You can 
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see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the Window menu, 

the following three methods that determine how drawings are arranged are provided for user's choice. 

 

-Cascade                                                                                      

-Tile Horizontally                                                                                            

-Tile Vertically 

 

 

 

 

 

 

4.4.5. View Manager 

With the view manager, you can create, set current, update layers, edit 

boundaries, and deletes named views, and switch quickly between each 

views, it is helpful to reduce many unnecessary view adjust operation. 

 

4.5. Specify a 3D View 

 You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and visualizing 3D models. You can 

specify a new viewpoint to create new objects or modify the existing objects. 

4.5.1. Set the Viewing Direction 

You view three dimensional drawings by setting the viewing direction. The viewing direction establishes the viewing position, 

When you view a drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. You can change the viewing 

direction to look at the drawing from a different vantage point or to work on a three 

dimensional model from a different orientation. 

To set a new viewing direction:  View >3D Views> Viewpoint Presets    Command 

line> DDVPOINT  

-Choose View > 3D Views > Viewpoint Presets                                                                   

-Set viewing angles at absolute to WCS and relative to UCS by moving the position of the 

needle according to your preference. Then click OK button. 

To display a plan view of the current drawing: View > 3D Views> Plan View     


















































































































































































































































































































































































